Low Beams not working

bothaa7

New Member
Messages
1
Likes
0
City
Cape Town
State
Non-US
Country
South Africa
What I Drive
Fiesta 2007 MK6
#1
Hi There, L & R Low Beams stopped working altogether. High beams are working, Multi swicth on steering wheel alternates between High and Low, one can feel the relays energizing both High ON and OFF which in turn switches Low beams ON / OFF. Both L & R fuses are good, and both relays, H & L-beams seems to be good. I swopped the relays around between H & L, conditions remained the same. I checked the Halogen bulb on at least the L-H side, swopped it out but new bulb did the same. I swopped back all to original and have to drive with H-Beams until this can be sorted. Is there another relay or fuse in the engin compartment perhaps that can affect the Low beams only??
 
Messages
121
Likes
125
City
Northern
State
CA
Country
United States
What I Drive
2015 Fiesta SE HB Magnetic
#3
Maybe a loose wire or bad contact behind the fuse box. Check that power is gettign to the fuse and leaving it. Check that the relay is getting power and leaving. Is power getting to the bulbs? Is power getting to the switch and leaving the switch? A lot to check, but methodicaly working from the power source through all the parts to the bulbs is the only way to find the proplem. [wrenchin]
 
Messages
145
Likes
89
What I Drive
'17 ST
#4
Maybe a loose wire or bad contact behind the fuse box. Check that power is gettign to the fuse and leaving it. Check that the relay is getting power and leaving. Is power getting to the bulbs? Is power getting to the switch and leaving the switch? A lot to check, but methodicaly working from the power source through all the parts to the bulbs is the only way to find the proplem. [wrenchin]
Go through all the contacts. Older cars can get some crud in there, especially if you drive in wet or wintry conditions. An improperly sealed connector or fuse anywhere can corrode over time.

It's usually something like that.
 


Top