• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Ford Fiesta Forum and Ford Fiesta community dedicated to Ford Fiesta owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Ford Fiesta Forum today!

Focus HWDA engine to 2009 FIESTA

Messages
3
Likes
1
City
Randburg
State
Non-US
Country
South Africa
What I Drive
Fiesta 1.6 2009
#1
Bought a FOCUS HWDA 1.4 engine to replace SPJA 1.4 on my FIESTA.

at the shop they said I just need to take out manifold and put my manifold on it and it will work. Now the engine is fitted the car starts but dies in 2-5 seconds.

What could be the issue?

Have replaced the fuel rail, injectors, spark plug and tested all them.
 

econoboxrocks

Senior Member
Premium Account
Messages
487
Likes
410
What I Drive
'17 ST
#2
I suspect the problem is in your ECU. The car doesn't know what to do with the different engine.
 

Hloni

New Member
Messages
2
Likes
0
City
Randburg
State
Non-US
Country
South Africa
What I Drive
2009 Ford Fiesta 1.6
#3
The wiring is the same though. What should I do on the ECU? Reprogram it or get one compatible with HWDA?

And why would the shop be so sure it works and they have seen it.. they also gave me 30 days warranty, left with 27 days as of today.
 

econoboxrocks

Senior Member
Premium Account
Messages
487
Likes
410
What I Drive
'17 ST
#4
I'd talk to them about it. They installed it, it's on them to make sure it runs.
 

Handy Andy

Senior Member
Premium Account
Messages
432
Likes
401
City
Grand Rapids
State
MI
Country
United States
What I Drive
2018 Ford Fiesta SE HB
#5
There were changes to the ECM wiring - so to hear it run then "dies" seems like an issue with the Fuel Pump or a timing sensor - again, might need to double check to make sure the pin for pin wiring to the ECM is correct. Else run with its HWDA that was part of that emission platform.
 
OP
H
Messages
3
Likes
1
City
Randburg
State
Non-US
Country
South Africa
What I Drive
Fiesta 1.6 2009
Thread Starter #6
There were changes to the ECM wiring - so to hear it run then "dies" seems like an issue with the Fuel Pump or a timing sensor - again, might need to double check to make sure the pin for pin wiring to the ECM is correct. Else run with its HWDA that was part of that emission platform.
Andy, you could be right.. the timing sensor wire connector was broken coming from the car wire harness, we took the connector from HWDA harness that came with it and connected them together but we couldn't differential which wire connects with as the colors of the wire is different. We said will come back to it and we never did (forgot) as we were looking at Fuel, air and spark.

Just to be sure the timing sensor is the one next to oil filter?
 

Handy Andy

Senior Member
Premium Account
Messages
432
Likes
401
City
Grand Rapids
State
MI
Country
United States
What I Drive
2018 Ford Fiesta SE HB
#7
That I cannot answer - but the one that the Fiesta uses, is blue colored - on the flywheel side - right by the transaxle/clutch mess - so it looks to the output side - not the harmonic balancer side.

Had to quick post, but I wanted to add...

After seeing - reviewing over your own car (as a new owner) you see these Sensors aligned and "clipped-on" using simple plastic what could also be considered a Potato(e?) chip clip spring wire - the critical sub-systems and their "sublime" install locations and methods - it's amazing these things even run.
 
Last edited:
OP
H
Messages
3
Likes
1
City
Randburg
State
Non-US
Country
South Africa
What I Drive
Fiesta 1.6 2009
Thread Starter #7
That I cannot answer - but the one that the Fiesta uses, is blue colored - on the flywheel side - right by the transaxle/clutch mess - so it looks to the output side - not the harmonic balancer side.

Had to quick post, but I wanted to add...

After seeing - reviewing over your own car (as a new owner) you see these Sensors aligned and "clipped-on" using simple plastic what could also be considered a Potato(e?) chip clip spring wire - the critical sub-systems and their "sublime" install locations and methods - it's amazing these things even run.
Thank you, we on the same page. its crankshaft position sensor, also colored blue. Its the one with a broken clip and had to fix it up. I will report back after looking into it.
 

Hloni

New Member
Messages
2
Likes
0
City
Randburg
State
Non-US
Country
South Africa
What I Drive
2009 Ford Fiesta 1.6
#8
My 2009 Ford Fiesta is alive with a Ford Focus HWDA 1.6 engine. The sensor didn't have any issue, the issue was timing was off, this happened when we took out the crank pulley and putting it back. It will loose timing. Putting it back to correct timing solved the issue. We drove it 397 miles (640 km) for a test drive on a high way. No fault codes.

Thank you Andy pointing me to the correct direction.
 

Handy Andy

Senior Member
Premium Account
Messages
432
Likes
401
City
Grand Rapids
State
MI
Country
United States
What I Drive
2018 Ford Fiesta SE HB
#9
Hey, glad to see you holding onto a piece of history and making it work.

Miles of Smiles.
 


Top