ABS & Traction Lights On Dashboard

#1
I've come up with another issue on my 2011 Ford Fiesta. Just 2 days ago before starting the engine. I will hear the dash a gling sound and there you go, My ABS, Traction Control and the Handbreak lights were On? Why all of sudden this is happening? Anyone knows how to fix this issue? After reading some opinions, it is safe to Turn Off this 2 (ABS & Traction control) i just want to know based on your experience with yours. And how did you deal with this..

But im still using my car and i dont have problems strolling around while those items where lit on my dash. Let me know if its ok using my car with these warning lights are on. Thanks in advance[:)]
 
#3
Thanks hotfocus. ill try checking that part and maybe have an underwash of the car also. Maybe those sensors got really dirty after a typhoon hit our tropical country. And i ran thru muddy roads also.. ill get back to you after i cleaned those 2 sensors at the front coz i guess i dont have sensors at the rear coz i only have drum breaks at the rear.. ill try my luck and hopefully i dont have a busted sensors. Thanks again
 
#4
Thanks hotfocus. ill try checking that part and maybe have an underwash of the car also. Maybe those sensors got really dirty after a typhoon hit our tropical country. And i ran thru muddy roads also.. ill get back to you after i cleaned those 2 sensors at the front coz i guess i dont have sensors at the rear coz i only have drum breaks at the rear.. ill try my luck and hopefully i dont have a busted sensors. Thanks again
Yeah definitely keep us posted.
 
#5
Sorry it took me a while to update. But yeah after a hard underwash on the car specially concentrating on the areas where the sensors are located, all the lights went out and it drives really smooth after travelling mostly 1k kms. It is a dirty ABS & Traction control Sensors that keeps me warned on the lights on my dash.

But after 3 days it went back again and guess what, before i only have 4 warning lights ( ABS, Traction 1 & 2, Handbreak ) Now the Engine light went on also. After researching it went on because of the symptoms of the 4 lights went on. That is why the Engine light is also turned on.

And when it did i also feel an unstable running. Meaning everytime it shifts i feel the car is being hold back before the car is released and sometimes i hear a knocking sound on the engine or the idling just went low. So i quickly put the gear into Neutral so that the engine wont die. And the worst part of the Engine light turned on. Is when i place the shift to Reverse, it wont back up and stays like im reving the engine on Neutral. I dont go nowhere even i want to back up the car or put the gear in Reverse.

So everytime i have that trouble. I just turn the key off. And i wait for about 10 seconds and starts the engine again. Thats the time the Reverse gear functions and the car backs up as i want to.

So after these problems. I just want to ask you guys, if Removing the Fuse of the ABS located at the engine, will help me solve these problems i experienced. But of course i know for sure that those lights on my dash will remain lit. And the ABS motor will not function. In a way. I was used in driving a conventional cars way back that doesnt have ABS features. But do you think, disabling the ABS on my ford fiesta is ok? Let me know what are your thoughts about this. Thanks again in advance
 
Last edited:


Top