Hello and welcome to our Ford Fiesta Forum community! Is this your first visit?
Register

Results 1 to 2 of 2
  1. #1
    New Member
    Medals
     
    Join Date
    Jun 2018
    City
    Canada
    Country
    Canada
    Posts
    1
    Rep Points
    1


    Has Anyone Else Had This Issue w/ Their 2013 Ford Fiesta?

    Guest-only advertisement. Register or Log In now!
    So earlier today I had just gotten home and was pulling into park at my house when all of a sudden my engine shut off, not the battery because all the lights were working but my phones AUX cut off and the only movement left was what was rolling. As of now the car wont start and im getting a car with a lock symbol blinking on my dash. I was told this was a issue with the anti theft but I have no idea how to fix this issue. I looked around and seen this is a common issue but no one really helped when it came to fixing the issue. The key will turn but the steering wheel wont.

  2. #2
    Member 7 Rep Points
    Medals
    Earned First 5 Rep Points  
    Join Date
    Dec 2013
    City
    Grass Lake
    State
    MI
    Country
    United States
    Posts
    68
    Rep Points
    7


    Disconnect the battery. you may have a control module that is failing or getting a bad signal. If you have any aftermarket electronic equipment installed, you might want to pull the plug on them. Fiesta is a CANBUS vehicle. It may have issues in various systems if there is an additional draw on a circuit that has a very specific voltage requirement. Make sure any non stock things are disconnected or off, then reconnect the battery after you inspect the terminals to be certain you have a good, clean contact surface. That is the first and only free thing I would do.


 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •