Hello and welcome to our Ford Fiesta Forum community! Is this your first visit?
Register

See the top rated post in this thread. Click here

Results 1 to 5 of 5
2 Likes

Thread: Ford Fiesta 2011 WONT START

  1. #1
    Member
    Medals
     
    Join Date
    Nov 2017
    City
    Makati
    Country
    Philippines
    Posts
    30
    Rep Points
    1


    Question Ford Fiesta 2011 WONT START

    Guest-only advertisement. Register or Log In now!
    Hi guys. Yesterday i ran out with another issue with my fiesta. IT WONT START!?!?!. I was wondering maybe my recently installed amplifier and subwofer killed the battery? But i doubt, coz i turn it on while driving the car or the engine is running. And the next morning when i want to turn on the engine. I got nothing. All the lights in the dash are on brightly and the park lights are clearly open. But when i turn the key all i got is a slow clicking sound and the car wont start. So i pulled out the battery and took it to the shop for charging. And they said the battery case was a bit bloated. But the battery is still fine but as soon as they remove it from charging, the voltage immediately dropped. So ive come with a conclusion that i need to replace the battery. But i want to know from you guys. Based on your experience. Is my battery dead because of my car audio. Coz the bass on my audio is really kicking good and i loved it But maybe it ate a lot of juice out of my battery and killed it? Also i checked all the fuses from the engine bay and in the dash its all ok. So what i got left is the battery to be replaced. Is it really the battery? That wont start the car even all the lights in the dash are on? Thanks in advance.

  2. #2
    Member 7 Rep Points
    Medals
    Earned First 5 Rep Points  
    Join Date
    Dec 2013
    City
    Grass Lake
    State
    MI
    Country
    United States
    Posts
    61
    Rep Points
    7


    1 members found this post helpful.
    If you have an amplifier, it is a huge power consumer. You might want to consider adding a second battery to add capacity to your system. It will give your alternator some relief. You should also recheck all the connections to ensure nothing is grounding out unintentionally. You might also want to check the underhood fusebox for corrosion of the connections. If you live very near the ocean, salinated air may be eating it up there.
    I believe that you will eventually smoke the alternator if you dont add a deep cycle battery in a post to post arrangement. You are asking a minimal electrical system to do a high demand job.

  3. #3
    Member
    Medals
     
    Join Date
    Nov 2017
    City
    Makati
    Country
    Philippines
    Posts
    30
    Rep Points
    1


    Thanks Scotman.. definitely i will add another battery just for the amp. Coz the Main Starter Battery now is Dead i mean theres no lights at all in the dash... Now all i need is a proper diagram on how to connect properly 2 batteries in my fiesta. I heard that i also need to add a battery isolator? to charge properly the 2 batteries? Or ill just add a connection and hook up 2 batteries in the alternator? Thanks again

  4. #4
    Member 7 Rep Points
    Medals
    Earned First 5 Rep Points  
    Join Date
    Dec 2013
    City
    Grass Lake
    State
    MI
    Country
    United States
    Posts
    61
    Rep Points
    7


    1 members found this post helpful.
    Quote Originally Posted by FROMDUB View Post
    Thanks Scotman.. definitely i will add another battery just for the amp. Coz the Main Starter Battery now is Dead i mean theres no lights at all in the dash... Now all i need is a proper diagram on how to connect properly 2 batteries in my fiesta. I heard that i also need to add a battery isolator? to charge properly the 2 batteries? Or ill just add a connection and hook up 2 batteries in the alternator? Thanks again
    Post to post means positive cable from under hood battery to rear battery positive post. Negative cable for additional battery is from its negative post to a good attachment location on the floorpan. Preferred place would be at frame point. I assumed that you had already wired in some kind of power shut off. Otherwise your amp will never shut down. That arrangement will kill even ten batteries, it would just take longer.

  5. #5
    Member
    Medals
     
    Join Date
    Nov 2017
    City
    Makati
    Country
    Philippines
    Posts
    30
    Rep Points
    1


    Thanks again Scotman i'll take your advice on the connections when i add an additional battery just for my amp. And just an update. I was able to get a New replacement Battery for the Fiesta. And its 50 amperes which is higher than the original (44 amp.) so i feel a lot more alive when i drive the car while kicking the bass of my amplifier. and i never get a power shortage. Maybe because its a new battery or because of a higher ampere rating of the battery coz its a bit bigger than the old one. But i'll just monitor the newly installed battery because it has only 15 months of warranty. hope it reaches or more before i replace it again. As of now its all fine and everything is working. no warning lights in the dash. And yeah I already placed a Kill Switch for the amp. coz just like what you said, it will always be On if i don't place a killer switch for it. Thanks again man appreciate it


 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •