Hello and welcome to our Ford Fiesta Forum community! Is this your first visit?
Register

Results 1 to 3 of 3
  1. #1
    New Member
    Medals
     
    Join Date
    Apr 2018
    City
    New York
    State
    NY
    Country
    United States
    Posts
    1
    Rep Points
    1


    Help to understand that with the car?

    Guest-only advertisement. Register or Log In now!
    Hello! Something happened with my Ford. The engine began to run unevenly, appeared to vibrate, and the oil consumption increased. Has anyone encountered this problem? What is the reason?

  2. #2
    Staff Team Staff Team 20 Rep Points MKVIIST's Avatar
    Medals
    Earned First 5 Rep Points  
    Join Date
    Jun 2013
    City
    Tempe
    State
    AZ
    Country
    United States
    Posts
    1,129
    Rep Points
    20


    Is it leaking oil? Have you checked your spark plugs for signs of oil?
    2014 Fiesta ST - 3M Window Tint, ESM Wheels, Bazooka Bass Tube, Rockford Fosgate Amp

    Want a free FiestaForum.org decal? Click Here
    Follow Us On: Facebook - Twitter - Flickr

  3. #3
    New Member 5 Rep Points
    Medals
    Earned First 5 Rep Points  
    Join Date
    May 2014
    City
    Rochester
    State
    MN
    Country
    United States
    Posts
    16
    Rep Points
    5


    Does it do that at just idle or all rpm's? The increase in oil consumption has me concerned. I guessing something in the engine mechanical, like a piston ring or valve seal. Tell us what year, engine and transmission. Please keep us posted to what you find out. Hope it's under warrantee.


 

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •